CLICK HERE TO REMOVE THESE ADVERTS


Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 12v fuses in Elddis Autoquest

  1. #1

    Member Number
    28701
    Join Date
    Sep 2012
    Posts
    34
    Motorhome
    camper van

    12v fuses in Elddis Autoquest



    CLICK HERE TO REMOVE THESE ADVERTS
    Hi
    Having problem with fluorescent light not working. Friend has tested & said there is no power to it & suggested I check fuse. Am not very technical, but thought I could manage that. But can't find fuses, have looked in manual, but not clear. Does anyone know where they are? Thanks

  2. #2

    Member Number
    23532
    Join Date
    Apr 2012
    Posts
    1,800
    Location
    Oxford
    Motorhome
    Pilote Galaxy 40
    From memory have a look under the seat on the side where the battery is and there should be a control box and the battery charger and the should be a fuse box as well, you may have to remove a wooden cover I'm not sure.
    I hope this helps.
    You can't be lost if you don't know where you're going.
    Likes Tezza33, Minisorella liked this post

  3. #3

    Member Number
    5407
    Join Date
    Feb 2009
    Posts
    9,766
    Location
    Derbyshire
    Motorhome
    Hymer 584 Classic
    There are fuses under one of the rear seats (I think offside), it is a 10amp fuse
    Thanks Lee thanked for this post

  4. #4

    Member Number
    19864
    Join Date
    Aug 2011
    Posts
    2,762
    Location
    Horsham, West Sussex
    Motorhome
    Compass Avantgarde 140
    I'm with Lee and Terry... my van's almost the same and my fuse box is definitely under the offside bench seat in the rear lounge. It's towards the wardrobe bulkhead but on the length of the bench opposite the van wall, if that makes sense. Mine is under a foot-long wooden cover that's easy to get off but the fuse box is still a little bit hidden under the front ledge.

  5. #5

    Member Number
    25133
    Join Date
    May 2012
    Posts
    13,755
    Location
    Glengormley
    Motorhome
    iveco iris lib bus
    When you do get it sorted id change to led.
    Only dirty people wash

  6. #6

    Member Number
    5407
    Join Date
    Feb 2009
    Posts
    9,766
    Location
    Derbyshire
    Motorhome
    Hymer 584 Classic
    Quote Originally Posted by Minisorella View Post
    I'm with Lee and Terry.
    I wish
    Likes Linda, Minisorella liked this post

  7. #7

    Member Number
    19864
    Join Date
    Aug 2011
    Posts
    2,762
    Location
    Horsham, West Sussex
    Motorhome
    Compass Avantgarde 140
    Lol! Now behave, or it'll be the gorgeous Maggie blowing a fuse
    Likes Tezza33 liked this post

  8. #8

    Member Number
    24599
    Join Date
    May 2012
    Posts
    2,808
    Motorhome
    Laika EcoVip 712
    Why oh why do they have to hide them. Whats wrong with putting them where you can see them. Ours are behind a clear plastic panel. Right where you would expect to find them on the outside of the battery compartment. You don't need any tools to get at them. You just need a torch and a prayer mat as they are about 200mm off the floor.

    Whoever now owns our old SWIFT will find I converted the strip lights to LED. I bought some LED's on a strip removed the tube and electronics from the fluorescent light stuck the LED's in place of the tube, wired them using the same terminals and put the whole unit back in again. Saves mucking and messing about

    ..
    Last edited by QFour; 22-04-2018 at 21:41.

  9. #9

    Member Number
    23532
    Join Date
    Apr 2012
    Posts
    1,800
    Location
    Oxford
    Motorhome
    Pilote Galaxy 40
    Quote Originally Posted by Tezza33 View Post
    I wish
    I would just like to make it clear I have never conspired with Tezza33 in any of his fantasies.

    I'm also quite annoyed that I didn't think of that reply before him but may be I'm just a bit innocent.
    You can't be lost if you don't know where you're going.
    Likes Minisorella, Tezza33 liked this post

  10. #10

    Member Number
    28701
    Join Date
    Sep 2012
    Posts
    34
    Motorhome
    camper van
    Thanks for all your advice. I had actually bought a replacement led tube before I realised that wasn't the problem! Have now discovered fuses, thanks. Bad news is, they look ok.
    Light was fine until recently. Any other ideas before I consult an expert?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •