CLICK HERE TO REMOVE THESE ADVERTS


Results 1 to 3 of 3

Thread: Fridge not working on mains

  1. #1

    Member Number
    42425
    Join Date
    Jul 2014
    Posts
    84
    Motorhome
    2003 Autocruise Starblazer.

    Fridge not working on mains



    CLICK HERE TO REMOVE THESE ADVERTS
    202556773267
    Interestingly, I tried The Laird's vent blocking tip, but as still works ok on gas I'm assuming it's a coincidence.
    The fuses on the Zig panel are intact, anyone got hints of what may be wrong and where I should start checking?

  2. #2

    Member Number
    42425
    Join Date
    Jul 2014
    Posts
    84
    Motorhome
    2003 Autocruise Starblazer.
    Looks like half my thread gone missing, was saying that my dometic 6270 or whatever it is has stopped working on mains, gas ok and don't know about 12v.

  3. #3

    Member Number
    16509
    Join Date
    Apr 2011
    Posts
    17,244
    Location
    bristol
    Motorhome
    sprinter banger
    find the 3 wires going to the 240v element [ power off , of course !] ignore the earth and test for continuity across the pos and neg . no continuity means dead element . replacement not too bad
    too blessed to be stressed
    Likes trevskoda liked this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •