CLICK HERE TO REMOVE THESE ADVERTS


Results 1 to 8 of 8

Thread: Engine management light

  1. #1

    Member Number
    8424
    Join Date
    Sep 2009
    Posts
    3,440

    Engine management light



    CLICK HERE TO REMOVE THESE ADVERTS
    Hi all. I have an intermittent flicker of the engine management light on my FIat 2.8 JTD 2004 motorhome, this happens when the engine is labouring up hill in highish revs, the hand book says it is injectors causing this fault, I have added injector cleaning fluid to the diesel in the tank and have just done 3500 miles to Spain and back, the light did not come on again for the most part, I had this problem on my previous van which had the same engine and I took it to S n J Fiat at Poole where they put it on their lift and I sat in the van on the lift when the mechanic banged about a bit under the engine bay and sprayed some lubricating fluid on what he described as the gate valve, this cured the problem on that van , so I wonder if my now problem is the same fault, any ideas anyone please?

  2. #2

    Member Number
    25133
    Join Date
    May 2012
    Posts
    15,023
    Location
    Glengormley
    Motorhome
    iveco iris lib bus
    Nop but i will say never lab a engine as it kills the big end bearing and also wears bores with excessive side thrust on piston skirts,change down and let the engine run free but not over revving.
    Only dirty people wash
    Likes RoadTrek Boy, Fisherman liked this post
    Thanks vindiboy thanked for this post

  3. #3

    Member Number
    27295
    Join Date
    Jul 2012
    Posts
    1,575
    Had exactly the same problem and cured in the same way. When the engine started to labour I used to lift my foot of slightly and it would come out of the limp mode. Underneath at the rear of the engine you will find the EGR valve in the exhaust line. A bit spray and a good open and close will rectify.
    Edit Same engine
    Last edited by shortcircuit; 27-03-2019 at 12:31.
    Likes Alf, trevskoda, Fisherman liked this post
    Thanks Alf, vindiboy thanked for this post

  4. #4

    Member Number
    8424
    Join Date
    Sep 2009
    Posts
    3,440
    My neighbor has a gadget that plugs into a socket on the van and it reads any faults recorded by the vans Computer ?, we played with this today and it said no faults or issues ? I take the point about labouring an engine and I don,t do that , it is just that going uphill with the van heavy in 5th gear as the speed dropped off I changed into 4th and tried to maintain my speed and this is when the light flashed, so off course I de accelerated and the light went out.any red light is a bit scary though .
    Likes trevskoda liked this post

  5. #5

    Member Number
    33289
    Join Date
    Apr 2013
    Posts
    235
    Motorhome
    motorhome. Rapido 986F
    Mine's in the garage now being sorted as my light came on and off for a while but whilst in Cardiff this weekend it came on permanently.
    Luckily van was booked in to have the cambelt/water pump an oil leak, new radiator and part exhaust pipe done too, now this
    Likes trevskoda liked this post

  6. #6

    Member Number
    15631
    Join Date
    Feb 2011
    Posts
    1,446
    Location
    langham rutland
    Motorhome
    B544
    mine came on checked the online answers and it was telling me i needed an oil change not what you want to hear just below madrid !, knowing id had it serviced before i came away i checked oil levels good and oil looked clean so i cautiously came home with red light on the whole time not good for the soul but garage simply hadnt reset the onboard computer because id had it done early before i went away??

  7. #7

    Member Number
    50391
    Join Date
    May 2015
    Posts
    3,918
    Motorhome
    see picture
    I don't think it is normal for the service due indicator to switch on the engine management light. I suspect there is more to it than you think.

  8. #8

    Member Number
    8424
    Join Date
    Sep 2009
    Posts
    3,440
    Quote Originally Posted by ozzy1955 View Post
    Mine's in the garage now being sorted as my light came on and off for a while but whilst in Cardiff this weekend it came on permanently.
    Luckily van was booked in to have the cambelt/water pump an oil leak, new radiator and part exhaust pipe done too, now this
    Ouch that sounds expensive, good luck hope all goes well.
    Thanks ozzy1955 thanked for this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •